Simples Hausmodell (Blender und Texturen)

Aus wiki.3d-modell.design
Wechseln zu: Navigation, Suche

Vorwort

Ich habe dieses Tutorial eigentlich nur für eine Person geschrieben, deswegen wird man hier mit du angesprochen. Die Bilder wurden verrauscht, da ich nicht will, dass sie jemand als Textur verwendet. Sollte sie jemand trotzdem verwenden ... tu's nicht!

Benötigte Utensilien

Was man unbedingt für dieses Tutorial benötigt ist - no na - Blender (ich empfehle 2.66, da ich auch damit arbeite, weil 2.7 noch "Neuland" in Sachen Dirext-X Export ist) und ein Fotobearbeitungsprogramm deiner Wahl. Weil ich mit Photoshop arbeite, werde ich keine Kürzel oder ähnliches beschreiben, das Wissen für dein Fotobearbeitungsprogramm musst du selber mitbringen. Dann brauchst du noch "ShiftN", das ist so ein LightRoom für Arme, erfüllt seinen Job aber recht gut und ist sogar kostenlos. Desweiteren wirst du für die Texturenfotos eine Handykamera Kamera die halbwegs gute Bilder macht brauchen. Auch die Auflösung sollte über 3000px*3000px groß sein, da man so die Fotos leichter bearbeiten kann, eh klar. Außerdem brauchst du auch Google Earth (oder den Wienplan). Fast vergessen: Das OMSI SDK wird natürlich auch benötigt!

www.blender.org www.shiftn.de

Fotografieren des Objektes

Wenn du dich dann irgendwann einmal aufgerafft hast, um ein paar Häuser/Objekte/what ever zu fotografieren, solltest du das nur unter bestimmten Bedingungen tun. Die beste Jahreszeit für Texturenfotos (von Häusern) ist der Winter bzw. der späte Herbst und frühe Frühling. Wieso? Ganz klar, keiner braucht das deppate Gestrüpp vor in seinem Texturenfoto, außerdem sind Bäume mit Blättern schwerer aus dem Foto zu retuschieren als welche mit ohne. Doch nicht nur das sind die Vorteile des Winters, sondern auch das Wetter. Bekanntlich ist es im Winter nicht sehr oft Sonnig, das ist auch gut so, da sich ein bewölkter Tag besser zum Fotografieren von Texturenfotos eignet, weils dann keine Schatten gibt. Die sind ohne großen Aufwand nicht zu beseitigen. Leider kann der Winter nichts gegen den Wiener Schilderwald machen, der bleibt auch dann bestehen. Jetzt sollte man halt auch bevorzugt an einem Tag gehen, wo alle Autofahrer mit ihren stinkerden Rostschüsseln von den Parkplätzen weg sind. Das musst du aber selber rausfinden, ist ja je nach Gebiet anders.

Jetzt machst du dich also voller Enthusiasmus zu deinem Zielort auf und fragst dich natürlich, wie du denn jetzt das blöde Haus abfotografieren sollst. (Ich will dich damit nicht als blöd darstellen, das ist rein sinngemäß gemeint! ;-)) Am besten macht man die Texturenfotos natürlich direkt gegenüber vom Zielobjekt, das klappt auch meistens so. Mit arg engen Gasserln hab ich keine Erfahrungen, aber da müsstest du dann selber experimentieren. Um zuhause Frust zu vermeiden, solltest du mehrere Fotos vom Haus machen, damit du ein unvorteilhaftes gleich nicht benutzen kannst.

Die Erstellung der eigentlichen Fototextur

Die ersten Schritte

Angenommen du hast jetzt drei Fotos von dem Haus "Uhfünfstraße 20" musst du dich natürlich für das beste entscheiden. Manchmal kann bzw. muss man mehrere verwenden, vielleicht weil sich das Gebäude nicht auf ein Bild ausgegangen ist o.a. Sachen. Nun, das beste Bild ist natürlich eines wo man möglichst wenig vom Schilderwald mitbekommt oder möglichst wenig Gestrüpp rein ragt. Hast du das gefunden, machst du jetzt den ersten Schritt zur Fototextur. Ich zeige dies anhand dem niedlichem Häuserl "Wagramer Straße 128" vor - an diesem Foto sieht man auch gleich, was man alles falsch machen kann: Fotografieren an einem nicht bewölkten Tag, nicht genau gegenüber vom Gebäude und ... eigentlich ist da sonst alles perfekt. Also, du öffnest jetzt ShiftN und haust das Bild erst einmal rein. Danach zeigt dir das Programm die EXIF Daten an, ist aber nicht relevant dafür. Danach klickst du auf "Automatische Korrektur", dies kann einige Zeit in Anspruch nehmen, muss aber nicht. Im linken Fenster siehst du das bearbeitete Bild, im rechten das unbearbeitete mit den "lustigen Linien". Danach speicherst du das Foto wieder ab.

Nachfolgende Korrekturen und Freistellen des Gebäudes

Wie in meinem Beispiel (rechts) zu sehen, ist das Haus trotzdem "schief", daher muss es geradegerichtet werden. Wenn du das fertig hast, musst du (naja, mehr oder weniger, ich machs halt so ... aber herst, ich bin Gott und alle machens so wie Gott es macht! :D) das Gebäude freistellen, so das eben nur noch das Gebäude im Bild da ist. Das schaut bei mir dann so aus, weil ich schon ein paar "Random" Dachtexturen und Schornsteintexturen habe. Die werde ich dir bei Zeiten auch schicken ... irgendwann. Am Ende siehts bei meinem Beispiel so aus.

Entfernen eines Baumes oder anderen Störfaktoren

Nun, wie schon einmal angesprochen macht sich eine Fototextur mit einem Baum nicht gut. Ich habe mir nach einiger Zeit sogar die Arbeit gespart, die Oberleitung wegzugeben, zum Glück nur bei einem Gebäude wo man sie eh leicht wegretuschieren konnte. Ich kann jetzt schlecht erklären wie ich den Baum wegretuschiere - für die Oberleitung gibts den Retuschierpinsel - aber ich versuch es mal trotzdem. Zuerst retuschierst du das leichtere weg - in meinem Fall ist das die Oberleitung und der hässliche Blendfleck. Hast du also die zum leichtesten retuschierenden Dinger entfernt, gehts an den Baum ran. Das ist eigentlich je nach Foto anders. In meinem Beispiel kopiere ich einfach einen Teil der linken Hälfte und verschiebe ihn über den Baum und passe ihn an. Dabei geht zwar diese Bandwerbung verloren, da ich die aber sowieso megaschirch finde (das Grün bereitet mir halt in Kombination mit dem Haus Augenkrebs) spielt das hier keine Rolle. Da dabei natürlich auch Dinge überdeckt werden, die garnicht Stören sollte man mit Masken arbeiten. Die ermöglichen es, einen Teil einer Ebene ohne Verluste einfach auszublenden. Natürlich musst du trotzdem den Retuschierpinsel schwingen lassen, aber alles im allen sollte das schon klappen. Bei mir schauts jetzt so aus.

Entfernen anderer Störfaktoren sowie historische Rekonstruierung

Ich weiß, der Name des Kapitels ist Nobelpreiswürdig. Nun, natürlich stören neben Bäumen auch andere Sachen. Wie man Autos eliminiert zeige ich vielleicht in einem anderen Tutorial, aber in diesem Beispiel hat mein Gebäude leider keines gehabt. Also, wie im Namen des Kapitels zu lesen, gehts jetzt darum alle anderen Störfaktoren zu beseitigen. Mich stört an meinem Beispiel ungemein diese depate halihop Werbung und das untere rechte Fenster, sowie der Schaltkasten und das Türl an der Wand. Letztere würde ich "rekonstruieren" wollen, aber durch den nervigen Schaltkasten wird das etwas schwieriger. Also wird das einfach rausgehauen. Im Grunde musst du genauso wie beim Baum handeln, das ist kein großer Unterschied.

Jetzt ist halt das Internet gefragt, da ich gleich sehen will, womit ich das Haus stattdessen anmalen kann, denn immerhin wird es 32 Jahre lang nicht immer gleich ausgesehen haben. Wie gut, dass es so viele Threads zur Wagramer Straße im twf gibt (25/25R/25K/25/26, etc.) und so viele perfekte Fotos von unserem TARS, da wird sicher ein Foto sein, wo auch dieses Gebäude drauf ist. Und siehe da, gefunden! Ich weiß zwar nicht, was genau da drauf steht, aber ich meine "FLEISCH WURST IMBISS" zu entziffern. Ist auf jeden Fall stimmiger als dieser halihop Dreck der es sicher nicht in die Endversion schaffen wird!! Nur das du es weißt, ich bezieh mich auf das erste Haus nach dem Eckhaus. Nun, da ich das weiß, kann ich das perfekt Rekonstruieren. Da das Haus auch damals schon diese Farbe hatte, muss ich mich auch nicht damit rumärgern. Dennoch muss ich aber einen gescheiten "Innenraumdummy" finden, weil ich find eine weiße Fläche jetzt nicht soooo originell. Eigentlich muss ich eh nur die Spiegelung von einem anderen Foto "einbauen" oder noch viel besser, die weiße Flächen einfach abdunkeln. (TARS' Foto: http://www.tramwayforum.at/index.php?action=dlattach;topic=2621.0;attach=20371;image)

Nun sieht es also so aus, und damit ist die Textur auch fast fertig.

Letzte Korrekturen und Anpassung der Größe

Da ein Foto, das gegen die Sonne fotografiert wurde, generell zu dunkel ist, helle ich in meinem Beispiel dieses auf. Ich weiß zwar nicht, ob das auch auf dein Foto zutrifft, aber egal.

Meine Beispieltextur ist aktuell 1509px*1192px groß. Da diese auch nach einer Skalierung keine vielfache von 2 wären, muss ich/musst du die Größe anpassen. Je nach dem, was sich anbietet wählst du entweder "Hochformat" (h/2px*hpx), "Quervormat" (bpx*b/2px) oder einfach "Quadrat" (bpx*bpx). In meinem Fall wähle ich letzteres, dann skaliere ich die Textur auf 1024px*1024px und exportiere sie als DXT1 dds.

Blender

Maße finden und der Einstieg in Blender

Nun, wo du deine Textur hast, solltest du mit dem Modellieren anfangen. Doch bevor du Blender öffnest, solltest du dir die Maße besorgen - und zwar von Google Earth. Die Maße für mein Beispielhaus sind ungefähr Breite = 13m und Länge = 14m. Unvorteilhaft bei mir ist, dass ich gleich das Dach weggelassen habe, aber egal, ich nehme mir einfach das Foto, dass ShiftN ausgespuckt hat.

Nun öffnest du Blender und denkst dir "ähhh? Wos jetz?" Zuerst drückst du NUM5 um in die Orthogonale Perspektive zu gelangen. Danach wählst du den Kubus mit RMT aus, so wählt man alles in Blender aus. mit TAB wechselst du in den "Edit-Mode", hier veränderst du dein Modell. Jetzt erkläre ich dir erst einmal, was die ganzen lustigen Knöpfe bedeuten.

  • 1: Hier kannst du ebenfalls zwischen den vielen Modi wechseln. Wichtig sind für OMSI aber nur Edit- und Object-Mode
  • 2: Hier kannst du die "Anzeigeart" des 3D-Fensters beschließen. Die sind eh alle selbsterklärend.
  • 3: Hier kannst du den Mittelpunkt deiner Auswahl einstellen. Sind ebenfalls selbsterklärend.
  • 4: Würde ich nicht ändern, bringen auch nichts, wenn du sie änderst.
  • 5: Hier kannst du den Auswahlmodus ändern.
  • 6: Hier kannst du einstellen, ob du durch dein Objekt "durchsehen" (also du kannst dann die Punkte/Flächen/Kanten auch durch andere auswählen) oder nicht durchsehen willst.
  • 7: Immer abschalten
  • 8: Wenn Snapping aktiviert wäre, würde er das automatisch machen sobald du [G] drückst, ist eine nervige Option, nicht zu empfehlen.
  • 9: Snapping. Standardmäßig ist das eingestellt, ich empfehle auf Punkt umzustellen.
  • 10: Hier könntest du ein Foto machen, aber kein Renderfoto .. naja, hab ich grad erst entdeckt :D

Wo wir das geklärt hätten, kann ich ja fortfahren.

Du wählst nun alles mit [A] aus - damit kannst du immer alles auswählen - und dann [G]. [G] steht für "grab", damit bewegst du deine ausgewählten Sachen. Wenn du danach [X], [Y] oder [Z] drückst, bewegt sich deine Auswahl nur auf dieser Achse. mit [SHIFT]+[X] z.B. würde sich die Auswahl auf allen Achsen bewegen, außer der, die du gedrückt hast (in diesem Fall würde sich die Auswahl nur auf der Y- und Z-Achse bewegen).

Jetzt drückst du [Z], damit sich der Kubus nur auf der Z-Achse bewegt und dann 1 - für einen Meter nach oben. Danach drückst du Enter und wieder TAB. Nun drückst du [N] um das Properties-Panel auszuklappen. Hier kannst du allerhand Dinge einstellen, aber das wirst du selber "erforschen" müssen. Mich interessieren jetzt nur die Werte bei "Dimensions". Hier gibst du nämlich jetzt deine Werte ein, lasst die Z Achse aber in Ruhe.

Nun teilst du das 3D Fenster, damit du ein UV-Mapping Fenster bekommst. Dies tust du, in dem du in der linken unteren Ecke vom 3D-Fenster das Dreieck anklickst und nach rechts ziehst. Juhu, das ist doch nur ein zweites 3D-Fenster? Ja, aber du musst die "Art" erst umstellen. Neben dem Dreieck im linken Fenster gibts wieder einen Button zum aufklappen, dort wählst du "UV/Image-Editor".

Jetzt gehst du wieder in den Edit Mode und änderst deine Ansicht - je nachdem wo deine Textur drauf soll - mit NUM1 oder NUM3. Kurze Erklärung dazu: Fahrzeuge werden immer mit der Front in +Y Richtung gebaut, sodass NUM1 das Heck ist, STRG+NUM1 die Front, NUM3 die Türseite und STRG+NUM3 die Fensterseite ist. NUM7 wäre das Dach und STRG+NUM7 der Boden.

Nun wählst du im Face-Auswahlmodus die Front deines Gebäudes aus und klickst im UV-Editor auf Image > Open Image und wählst deine Textur aus. Danach drückst du im 3D-Fenster [U] und wählst "Project from view (Bounds)", jetzt passt du jetzt die Punkte im UV-Editor so an, dass sie nur das eigentliche Gebäude umfassen. Die Shortcuts sind dieselben, nur gibts halt keine NUM-Ansichten und keine Z Achse, das ist wichtig weil die Z-Achse im UV-Editor die Y-Achse ist. Das fall ich auch nach zwei Jahren noch drauf ein. :( Um mehrere Punkte auszuwählen kannst du sie entweder mit RMT und SHIFT+RMT auswählen oder [B] für eine Auswahl "zum Ziehen" oder [C] für den "Auswahlspinsel".

Natürlich kannst du die Textur noch nicht sehen, weil du erst in die Texturenansicht wechseln musst. Ups, trotzdem alles schwarz? Das kommt von diesem blöden Punkt der zwei Mal strichliert umkreist ist. Den löscht du jetzt, im Object Mode! Und tadda, hier ist die Textur.

Nun gehst du wieder in den Object-Mode um die Höhe anzupassen. Dazu wählst du das "Gebäude" aus und drückst [S] zum Skalieren. Und hier das gleiche wie bei [G] - wieder [Z] drücken und mit der Maus so herumschwenken, dass es höher wird. Da musst du jetzt selber abschätzen ob das gut aussieht oder nicht. Alternativ kannst du das natürlich auch bei den Dimensions machen.

Wenn du die perfekten Proportionen gefunden hast, gehst du wieder in den Edit Mode und wählst die untere Kante der Front aus - im Kantenauswahlmodus. Dann kopierst du sie mit SHIFT+[D] - hier gibts kein Einfügen!! - und drückst gleich [Z] und verschiebst es auf die Kante zwischen Dach und Fassade.

Nun wählst du die Ecken aus die die Front einschließen und drückst [W] und klickst dann auf "Subdivide". Danach sollte eine Kante in der Mitte erscheinen. Die snappst du auf die Dachkannte . Ja super, das schaut jetzt aber schiach aus. Na, das schreit ja förmlich danach im UV-Editor korrigiert zu werden! ;). Das selbe machst du dann mit der gegenüberliegenden Seite. Einfach gehts, in dem du die Fläche löscht und dann die Frontflächen einfach kopierst und dort hin snappst. Dann einfach [W] und "Flip Normals" und wieder [W] "Remove Doubles". Danach kannst du, sofern dein Gebäude wie meines ein Spitzdach hat, die oberen Kanten auswählen und [S] zum Skalieren und auf der jeweiligen Achse 0 drücken. Ich bin mir gerade unsicher, ob du das verstehen kannst, aber wozu gibts das Forum/Skype? :/ Bei mir schauts dann so aus.

Materialien

Damit OMSI auch die Texturen erkennt musst du Materialien definieren. Der Kubus am Anfang hat schon eines, das können wir abwandeln. Ich gehe davon aus, dass du nur eine Textur hast, erkläre aber nebenbei Trotzdem, wie man mehrere Materialien einem Objekt zuweist. Für uns wichtig ist nur "Diffuse" und "Specular". Diffuse stellst du auf 1, Specular auf 0, wir wollen ja keinen Glanz haben und die Textur in voller Helligkeit. Danach wechselst du auf das Schachbrettsymbol oben rechts, hier definierst du die Textur. Bei Type wählst du "Image or Movie" aus. Dann klickst du auf "Open" und wählst deine Textur aus. Sofort danach öffnen sich neue Fenster, deswegen musst du ein bisschen runterscrollen bis du auf "Mapping" triffst. Dort stellst du bei "Coordinate" auf UV. Fertig! Das Material ist fertig definiert und du könntest das Objekt theoretisch sofort nach OMSI Exportieren. Wäre da nicht die Tatsache, dass man nicht auch mehr Materialien verwenden könnte. Um mehr Materialen, also Texturen, für ein Objekt zu definieren, drückst du wieder in dem Fenster was rechts abgebildet ist neben dem oberen "Material" auf das +. Dann auf "New" und jetzt musst du wieder das selbe Prozedere durchmachen. Es schaut kompliziert aus, aber nach einiger Zeit wird das zur Routine. ;-)

Nun, damit die gewünschten Flächen das gewünschte Material haben, musst du diese auswählen und dann das gewünschte Material auswählen und "Assign" drücken.

Dirext-X .x Export

Die Option für den Export von .x Dateien ist standardmäßig nicht aktiviert. Dazu musst du erst unter File > User Preferences auf "Addons" und dort auf "Import-Export" gehen und dann ein Hackerl beim .x Exporter machen. Dann speichern und das Objekt auswählen. Nun gehst du zu File > Export > DirectX (.X). Da kommen wieder lustige Einstellungen, verwende immer diese!

Damit hättest du deine erste .x Datei - herzlichen Glückwunsch!

OMSI

OMSI-X-Converter

Der OMSI X Converter konvertiert deine .x Datei in eine .o3d. Je nach Größe deiner .x kann das eine Weile dauern.

SCO und OMSI Ordnerstruktur

Um dein Objekt zum Laufen zu bringen, benötigst du mindestens einen Ordner namens "texture" und "model" in einem Ordner im Ordner "Sceneryobjects"!

In den Ordner model gibts du deine .o3d rein, in den Ordner texture deine Texturen.

Die .sco für dein Objekt wird recht simpel sein, hier eine Art "Template":

[groups] {Anzahl der Kategorien im Editor} {Name der Kategorie}

[friendlyname] {Name des Objektes im Editor}

[NightMapMode] Modus wie Nachtbeleuchtung eingeschaltet werden soll: 0: wie Straßenbeleuchtung 1: Gebäude mit durchgehender Beleuchtung 2: Wohngebäude (nicht zwischen ungefähr 23 und 6 Uhr inkl. Variation) 3: Gewerbegebäude (nicht zwischen ungefähr 18 und 7 Uhr inkl. Variation) 4: Schule (nicht zwischen ungefähr 15 und 7 Uhr inkl. Variation)

[NightMapMode] {Wann scheint das Licht?}

[mesh] {Dateiname}.o3d

[collision_mesh] {Dateiname}.o3d

[shadow] //lasst den Schatten fallen

[fixed] //Objekt bleibt stehen, auch wenn du mit dem Bus reinkrachen würdest.

Nun kannst du dein Objekt im Editor laden und stolz auf dich sein. Wie man Nachttexturen erstellt erkläre ich ein andermal *gähn*.